Forum
Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC:

Carbon Welding buggy ? 5 months 2 weeks ago #953

  • FSJC
  • FSJC's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 2
  • Thank you received: 0
Hey guys,

I'm trying to animate a Carbon Welding's activation and stiffness, but after I set keys and scrub through the timeline, the attribute editor doesn't seem to be showing the correct values. It seems to update initially, but then gets stuck at a value no matter what frame I'm at.

With Activation, this seems to only be a visual bug though, the welding actually activates/de-activates as I would expect it to (and when I check the graph editor I can see that the keys are correct, just in the attribute editor the values are not correct)

With Stiffness, I can't seem to get it to be any softer. What I want to do is gradually have the welding loosen (rather than the instant release that I get when I turn the Activation to 0). I've tried animating Stiffness all the way to 0, but visually, it looks like it still maintains the same stiffness (10) that I started at. I have turned on the "Animated" checkbox. 

Any help appreciated ! 

Thanks !

Please Log in or Create an account to join the conversation.

Carbon Welding buggy ? 5 months 1 week ago #954

  • admin
  • admin's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 207
  • Thank you received: 28
Hi,  Thanks, there does appear to be a UI bug with the welding stiffness, where the value in the UI does not change as you go and click along a keyed timeline, even though the keys are visible in the key table.  For me it still animates the stiffness values just fine. I set the values using the timeline just as usual.
Testing with Maya 2024.1 in Windows 11

Here is a video based on our pocket watch downloadable example in the docs.
It shows both animating the stiffness of the actor welding at the top of the cloth and near the end of the video the rigid welding for the button.
vimeo.com/892235403/da9808455c?share=copy

If you are still having issues getting any result from change in stiffness, maybe increase the weight of whatever is welded, the cloth or rigid, to check that its working.

Let us know if we've missed something here and if you are still having issues maybe a small reproducable that you can share with us would be the next step. Meanwhile we will get the UI bugs fixed in the next release, probably Jan/Feb next year.

Thanks,
Mike



 
The following user(s) said Thank You: FSJC

Please Log in or Create an account to join the conversation.

Last edit: by admin.

Carbon Welding buggy ? 5 months 1 week ago #956

  • FSJC
  • FSJC's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 2
  • Thank you received: 0
Thanks for the quick reply and that video !

I tried it on a piece of flat cloth and it wasn't releasing when I reduced stiffness to 0. But my requirement to do this has gone away for the moment, I'll get back on it in the new year probably and try it once more. Maybe I was doing something wrong. 

Thanks again !

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
Time to create page: 0.073 seconds